Take me to pcigeomatics.com

PCI Geomatics Help Center

How can we help you today?

Stereo DEM Extraction from Radar Imagery

PCI Geomatics -

The purpose of this tutorial is to provide the steps necessary to extract a stereo DEM model from Radar imagery. This method of DEM extraction is useful if you do not have high resolution optical imagery available. However the quality of the DEM extracted from Radar data is lower than a DEM extracted from high resolution optical imagery. The selection of radar datasets is very important in this methodology. When using radar imagery you must take into account that there will be artifacts, such as layover and foreshortening present in the images. To minimize the effects of these artifacts, you want to choose images from the same pass direction but with slightly different incidence angles. For best results, the incidence angles of the images should vary by at least 10 to 20 degrees.

The data used in this tutorial is available as a sample dataset from MDA (ftp://rsat2:yvr578MM@ftp.mda.ca/Vancouver%20Dataset). The imagery used in this tutorial is Radarsat2 data of Vancouver Canada. The images cover similar areas and there is a large overlap between the two images. The data was collected from two different descending passes with right look directions. The images have different beam modes, with one image having a Wide 2 beam mode and the other a Standard 7 mode. The resolution of W2 and S7 images are similar and therefore suitable for this method of DEM extraction. The incidence angles of W2 and S7 images vary by around 10 degrees. The large overlap and variability in incidence angles allows for the collection of epipolar pairs and extrapolation of elevation values through correlation techniques.

In this tutorial the HH polarizations from each image will be used to extract the DEM. If you load the two images as RGB in Focus, you can see the parallax between the images. The red and blue pixels in the mountainous area show the differences between the two images. This parallax is caused by the difference in viewing geometry between W2 and S7 beam mode.

 

Project Setup

1. Open OrthoEngine from the Geomatica 2015 toolbar.

2. From the OrthoEngine toolbar click on File > New

3. The project Information window opens.

  • Enter a Filename for the project. Browse to your destination folder with the Browse button. Name the project and enter a description.
  • In this window, under Math Modeling Method, choose Radar Satellite Modelling.
  • Under Options select Toutin’s Model.
  • Click OK

4. The Set Projection window will open up. Click Cancel to close this window. The projection information will automatically be set once you add your first image.

5. Another pop-up window will appear and click OK.

 

Open Image Files in OrthoEngine

1. On the OrthoEngine toolbar select Data Input from the Processing Step drop down menu.

2. Select Read PCIDSK File.

3. In the Open Image Window click Add Image.

4. Open the folder RS2_OK871_PK9035_DK3227_S7_20080503_141307_HH_HV_SGF. Choose the product.xml file and click open. Choose Calibration Type: None in the next window and choose No to building overviews.

5. A pop-up will appear after you add the first image. Click OK.

6. Repeat steps 3 and 4 to open the second image from the RS2_OK871_PK15478_DK14704_W2_20080530_142538_HH_HV_SGF folder.

7. Close the Open Image Window.


Automatic Stereo GCP Collection (Optional)

1. On the OrthoEngine toolbar change the processing step to GCP/TP Collection. Choose Collect GCP Points Automatically

2. The Automatic GCP Collection window will open. Make sure to select your reference image and DEM/Constant Elevation.

3. Select the images that you want to use for GCP collection in the images section.

4. Check off the box next to Stereo GCP’s. Two options will become available. To sample a specific number of points click Count and choose a number. To sample points at a specific spacing interval click Spacing and choose the spacing number and a unit of measurement.

5. Leave the rest of the options as the defaults

6. Click Match GCPs

7. To view the residual errors for the collect GCPs click Compute Model.

8. If you are satisfied with the collected GCPs click Add GCPs to Project.

 

Automatic Tie Point Collection and Build Model

Tie points are ground features that are identifiable on both images. These features are used as reference points to connect the two radar images. Tie points must be collected where there is overlap between the two images. OrthoEngine has a tool which can automatically collect tie points.

1. Choose Automatically Collect Tie Points.

2. When the Automatic Tie Point Collection window appears keep all of the defaults and click Collect Tie Points.

3. Switch the processing step to Model Calculations and select Compute Model.


Generate Epipolar Pairs

Epipolar pairs are stereo pairs which have been reprojected to ensure identical orientation. Using epipolar images increases the speed of the correlation process and reduces the possibility of incorrect matches.

1. On the OrthoEngine toolbar switch the processing step to 3-D Operations.

2. Choose Create Epipolar Image.

3. The Generate Epipolar Images window opens.

  • Choose the S7 image for the left image and the W2 for the right. Both the left and right side boxes must have a blue highlighted image.
  • Click Add Epipolar Pairs to Table.
  • Click Generate Epipolar Pairs.

 

Extract DEM from Epipolar Image

OrthoEngine includes a tool which will automatically extract x, y and z values from the overlapping epipolar pairs and generate a DEM.

1. Select DEM from Stereo from the OrthoEngine Processing step drop down menu.

2. Choose Extract DEM Automatically.

3. The Automatic DEM Extraction window opens.

  • Check the Select box.
  • Leave the DEM Extraction options with default values.
  • In the Geocoded DEM section check Create Geocoded DEM.
  • Choose an output filename and location.
  • Choose a resolution size. In this tutorial 50 is used, which is double the pixel size. Choosing a smaller pixel size will produce a higher resolution DEM but will take longer to extract.
  • Click Extract DEM. This process will take some time to run.

4. Once the extraction is complete, save your OrthoEngine project (File > Save on the OrthoEngine toolbar).

 

View Extracted DEM

1. Open Focus from the Geomatica toolbar.

2. In Focus open the extracted DEM. Select File > Open > navigate to the DEM file.

3. The DEM will load into the viewer. You can see that the DEM is not very smooth. This is a result of the resolution selected when extracting the DEM. If you would like a smoother output, change the resolution in the Automatic DEM Extraction Window in OrthoEngine and regenerate the DEM.

4. Open the two images that were used to generate the DEM. You can compare the DEM to the imagery to determine the accuracy of the DEM. In the image below the colored DEM has been overlaid on the imagery to show areas of inaccuracy. You can see in the image below that there are interpolation errors in the water. Areas of the DEM can be edited manually using the live DEM editing tool.

Toutin’s model was used in this tutorial (Project Setup: 3.c). When Toutin’s model is chosen for Radarsat-2 data, Toutin’s Hybrid model is automatically used; this model is a combination of the Toutin’s and Rational Function models.

There are two other math models that you can use to complete DEM extraction from radar imagery. The Radar Specific Model makes use of different satellite geometry information so fewer GCPs are required. Collecting GCPs is optional but recommended to increase the positional accuracy of the images.

Tie points are not collected by this model since the position of each image is computed by the GCPs. The final option is the Rational Function model which can only be used with Radarsat-2 data. Radarsat-2 includes RPCs which are required by the Rational Function Model. The benefit of this model is that very few GCPs are required.

Generally only 1 or 2 are enough to ensure accuracy. Both the radar specific and rational function models will produce a DEM that is relative to the ellipsoid rather than mean sea level. The resulting DEM can be converted to mean sea level using Tools > Convert DEM Datum.

 

Have more questions? Submit a request

Comments

Powered by Zendesk