Take me to pcigeomatics.com

PCI Geomatics Help Center

How can we help you today?

Manual Mosaicking

PCI Geomatics -

Manual mosaicking allows you to mosaic individual image files or edit unsatisfactory images and/or cutlines in files that were created using the automatic mosaicking tool. The following tutorial outlines the basic steps involved in mosaicking a series of orthorectified images using only the manual mosaic tool in OrthoEngine.

New colour balancing tools have been added in Geomatica 2015. These are available in the Manual Mosaic tool after creating an automatic mosaic with the bundle adjustment option. For more information about editing an automatically mosaicked image and using the new tools you can read the Automatic Mosaicking tutorial.

For the purpose of this tutorial, we will create a new OrthoEngine project using “None (Mosaic Only)” for the Math Modeling Method. This method can be used if you have a series of georeferenced images available. If your images are not georeferenced, you can orthorectify and manually mosaic the images by choosing a different OrthoEngine project type.

 

Project Setup

1. Open the Geomatica 2015 OrthoEngine application

2. From the OrthoEngine Toolbar click File > New

3. Give your project a Filename, Name and Description

  • Select None (mosaic only) as the Math Modeling Method
  • Click OK

4. Input the appropriate Output projection and Resolution for the project.

 

Adding Images to the Project

 

No geometric correction is performed for Mosaic Only projects. Therefore, the output projection and pixel spacing must be the same as the input files.

1. On the OrthoEngine window in the Processing Step list, select Image Input.

2. On the Image Input toolbar, click Open a new or existing image. The Open Image dialog box opens.

3. Click Add Image…

4. From the appropriate folder use <<shift>><<left mouse button>> to select multiple files. In this example, 2 images were loaded: P001.pix and P004.pix.

5. Save the project. To save your project file, select Save from the File menu in the main OrthoEngine toolbar.

 

Mosaicking
1. On the OrthoEngine window in the Processing Step list, select Mosaic.

2. On the Mosaic toolbar, click Define mosaic area.

3. The Define Mosaic Area dialog box opens.

4. In the Mosaic File box click Browse. Find the folder that you want to save your mosaic file in and give it a name. You can uncheck “Create Later” if you want to create the mosaic immediately.

5. Click OK. You can also select an existing file or change your image selection in this panel.

 

The Mosaic Tool
1. On the Mosaic toolbar, click Manual mosaicking. The Manual Mosaic Tool window opens.

2. You can access the major tools from:

  • The “Tools” menu
  • The icons in the toolbar or
  • Right mouse click on “Cutline”, “Label”, “Local mask” or “Match area” under each image in the file tree.

Tools Menu

 

•    Image Status: Allows you to set the status of a selected image or images. Options include: Verified, Unverified.

•    Enhance: Allows you to enhance the layers currently displayed in the View pane. Options include:

  • None
  • Linear
  • Root
  • Adaptive
  • Equalize
  • Infrequency


•    Normalize: Allows you to normalize the images using one of the standard normalization methods. Options include:

  • None
  • Hot Spot
  • Adaptive Filter


•    Color Balance: Allows you to apply a global or single color balance function to the data being mosaicked. Options include:

  • None
  • Manual Area
  • Overlap Area


•    Collection Viewer: Launches the Collection Viewer window, which allows you to work on the currently selected or active image.

•    New Cutline: Enables vector editing mode, which allows you to collect new cutlines or modify existing ones.

•    New Mask: Enables vector editing mode, which allows you to create an exclusion mask to use for color balancing.

•    New Match Area: Enables vector editing mode, which allows you to collect new match areas or modify existing ones.

•    Select Channels: Opens the Channel Selection window, allowing you to map specific input channels to output mosaic channels.

•    Add to Mosaic: Adds the active or selected layers to the output mosaic file. If Create Later was checked in the Define Mosaic options, the system creates the output file, then burns the new image. The new mosaic layers appear under the output mosaic file in the tree list.

 

Icons in the Toolbar

Button

Label

Description

Add Image(s) to Session Opens the Add Image window, allowing you to add images to the current mosaicking process. The Add Image window lists all images files available in the current OrthoEngine project.
   Undo / Redo  Cancels or restores the last action.
   Zoom To Overview  Zooms to display the entire image in the View pane.
   Zoom Interactive  Zooms in on the user-defined area of the image. Click and drag an area of the screen to define the zoom area.
   Zoom In / Out  Zooms in or out of an image.
   Zoom 1:1  Zooms to a 1:1 resolution of the current image.
   Pan  Enters pan mode, allowing you to dynamically move the image around the View pane. Click and drag to move the image.
   Image Status  Allows you to set the status of a selected image or images. Options include: Verified, Unverified.
   Enhancements  Applies enhancement options to the currently selected image or layer. Options include: None, Linear, Root, Adaptive, Equalize, Infrequency, Tail Trim, Exclude Min/Max, Set Trim %
   Contrast  Controls the difference between the light and dark extremes for all images displayed.
 Brightness  Controls the overall luminosity (amount of light) for all images displayed.
 Normalization  

Applies normalization options to all images displayed.

Options include: None, Hot Spot, Adaptive Filter
 Color Balancing  

Allows you to apply a global or single color balance function.

Options include: None, Manual Area, and Overlap Area. The "Match Area" option is available only if match area shapes exist for the selected or active image.
 Cursor Control  Displays the Cursor Control window, allowing you to define the cursor position in three different coordinate systems: raster, geocoded and in a user-defined projection. You can move the cursor in any of the supported coordinate systems by changing the associated coordinates.
 RGB Mapper  Opens the RGB Mapping window.
 Map Layer Selection  

Allows you to select a raster image layer in the View pane. The selected layer appears highlighted in the Control panel.

  • Single-click to select the top-most raster at the cursor location
  • Click-and-drag to select all layers touched
Control-click to select multiple images
 Flash Selected Map Layers  Allows a selecting image in the Mosaic Viewer or in the tree list to flash for easy recognition.
 Add Image To Mosaic  

Adds the active or selected layers to the output mosaic file. If Create Later was checked in the Define Mosaic options, the system creates the output file, then burns the new image.

The new mosaic layers appear under the output mosaic file in the tree list.
 Collection Viewer  Opens the Collection Viewer window, which allows you to work on the currently selected or active image.
 Vector Editing  

Displays the Vector Editing toolbar, allowing you to modify existing cutlines, exclusion masks, and match areas in the pixmap.

Options include: Find, Reverse Vertices, Add Vertices, Start Vertex, Previous Vertex, Midpoint, Next Vertex, End Vertex, Show Vertices, Vertices Information
 New Cutline  

Enters vector editing mode, allowing you to define new cutlines. Applies to the currently selected or active image.

Options include: Polygon, Rectangle, Ellipse
 New Mask  

Enters vector editing mode, allowing you to create a new exclusion mask for color balancing. Applies to the currently selected or active image.

Options include: Polygon, Rectangle, Ellipse
 New Match Area  Lets you collect polygons for the active image that will be used to apply a manual color balance function.

 

Cutline Collection and Editing

The next step is to collect cutlines for each of the images. Editing the mosaic can be done in the Mosaic Tool or in the Collection window. The Collection Viewer window in the Mosaic Tool provides a full-resolution, close-up view of the active (working) image, allowing you to generate or refine cutlines and match areas in the entire image, using a 1:1 resolution view. In this window, cutlines are drawn on top of the image, with the entire image being displayed by default.

The extents of this window are defined by the active image. All neighboring images are displayed, but you can toggle their display on or off using the toolbar buttons. You can also change the layering order the displayed images by changing their order in the Image Tree List.

The following table describes the additional buttons available on the Collection Viewer toolbar.

Button

Label

Description

 

Load Cutline

Opens the Import Cutline window, allowing you to load vector cutlines from an existing vector file. Imported cutlines apply to the active file displayed in the Collection Viewer.

 

Display Underneath Neighbors

Toggles the display of neighboring images that are positioned below the active image. The default view is on.

 

Display Working Image

Toggles the display of the active layer. By default, this display is on.

 

Display On-Top Neighbors

Toggles the display of neighboring images that are positioned on top of the active image. By default, this display is off.

 

Enable Cutline Clipping

Toggles the activation of cutline clipping for the active image. When this button is toggled on, only the data that is within the cutline is displayed. When it is toggled off, the entire active image is displayed. The default is off.

 

Visualization Mode

Determines the way in which the active image is displayed. Options include: Standard, Overlay Red, Overlay Green, Overlay Blue, Interleave.

 

Set Blend Width

Opens the Set Blend Width window, allowing you to change the pixel value of seam blends for the cutline.

 

Drawing a Cutline

We will first create the cutline in the manual mosaic window and then open the collection viewer window to examine the cutline.


1. Select the first image by clicking on the file in the files tree.

2. Click on the New Cutline icon  . The dropdown menu includes Polygon, Rectangle and Ellipse options.

3. Position the cursor where you want to begin collecting the cutline.

4. Draw a polygon around the part of the image that you want to be included in the mosaic.

5. Make sure to include only the best sections of the image while retaining an overlap between the images. Once you have outlined a cutline polygon, hit the Enter key or double click to close the cutline. You can use the undo toolbar button to remove a bad cutline.

NOTE: To make the seams between images less visible, select features which are consistent in tone and texture, low to the ground, uniform in appearance and conspicuous, such as roadways and river edges. Features that display clear boundaries provide a natural camouflage for the seam.

Avoid:

  • Buildings or man-made features since they may lean in different directions in the imagery.
  • Large bodies of water, because waves may look different between images.
  • Water also tends to be of different color in different images.
  • Areas which are significantly different in color and texture, such as forests and cultivated land.

 

 

Edit a Cutline
In this example we will use the Collection View to edit the cutline.

1. In the main window select your working image from the image tree list. Click the Collection View button

2. The collection viewer opens and your working image is shown on top. Using the neighbors toggle button you can choose to display the neighboring image underneath.

3. Zoom into one section of your image along the cutline that overlaps the neighboring image. You can experiment with blend width, contrast, brightness and visualization mode.

4.To edit the cutline, click on the Vector Editing Toolbar icon

The Vector Editing Tools window opens. You must select the cutline using the find button in the vector editing toolbar. Once selected, the vector editing tools will be available.

5. You can add verticies or move current verticies and reshape your cutlines. For instance you may wish to reshape cutlines that fall in a waterbody since these are likely to change colour across the images. In the images below a cutline through a lake has been edited. You will also notice that the cutline clipping is enabled in the second image. This option allows the user to clip the working image to the cutline.

6. Collect the cutlines for the remaining images as outlined above. If desired, you can correct any radiometric pattern in your images by simply selecting each of the images and using the Normalization tool to apply a Hot Spot correction to the image. If the results are not satisfactory, simply use the undo tool to remove the normalization from the image by using the “None” option in the Normalization tool. You can then proceed to the color balancing step.

 

Color Balancing
Color Balancing in Manual Mosaicking can be done in two ways: Manual Area or Overlap Area.

Manual Area: The Manual Area color balancing method is based on the match areas that you identify in the overlapping sections of the image. These match areas are used to compute a lookup table (LUT) that adjusts the color in the image that you are adding to match the images that will be mosaicked first.

Overlap Area: The Overlap Area color balancing method computes the color balancing histogram using only the pixels in the overlapping area of the images being added to the mosaic file.

NOTE: The strategy for collecting overlap areas will vary from image to image. If the input images are similar in appearance, you can collect a single match area in the overlapping area between two images to achieve a good color balance between the images. However, you can collect several match areas if desired. For example, you can collect small match areas representing the different areas so the lookup table can be used to accurately correct radiometric mismatches. For example, collect a match area in green area to balance greens, a match area in dark area to match dark values, a match area in urban areas to match urban areas, and so on. Using a single large match area covering a large part of the overlapping images tends to only be effective if you have an overall bright or dark difference between the images.

1. To do a color balancing with Match Areas, select the image in the file tree and click on the New Match Area icon to begin the color balancing process.

2. Draw the match area(s) in the main or collection viewer. 

3. To apply color balancing to the image, click on the Color Balancing icon pull down menu. Choose between the Manual Area and Overlap Area to perform color balancing. If you don’t have match areas for the selected image, this option will be disabled. If you are unsatisfied with the color balancing outcome, click on the Color Balancing pull down menu and click on None; or hit the ‘Undo’ button which will apply the previous color balancing outcome.

4. You can set the blend width using the cutline blend width option. This determines the number of pixels on either side of the cutline that are used to blend the seam. In the main viewer, right mouse click on the cutline for each file and select “Set Blend Width”. The value used will vary depending on the input images but a value of 0 – 5 is generally used.

In the collection viewer, you can use the “Set Blend Width…” tool

Blending reduces the appearance of seams by mixing the pixels values on either side of the cutline to achieve a gradual transition between the images. In the Manual Mosaicking Tool, the Blend Width determines the number of pixels on either side of the cutline that are used to blend the seam.

Note that in areas containing bright or significantly different features, setting the Blend Width too high may cause "ghosting" or doubling of the features.

 

Creating the Mosaic
1. To create the mosaic in the Mosaic Tool window, hold down the CTRL key and click on the images you want in the final mosaic.

2. Click on the Add Image(s) to Mosaic icon

3. Once the mosaicking process is completed, the output mosaic file will become active in the Mosaic Tool window. Once the image has been added to the mosaic, it will be removed from the list of input files.

4. If you want to reprocess any of the files in the mosaic, simply right click on the image name under the mosaic file and select “Reprocess”.

For more information on Manual Mosaicking please refer to the Geomatica Help under the keywords “Mosaicking Images Manually”.

 

 

Have more questions? Submit a request

Comments

Powered by Zendesk