Take me to pcigeomatics.com

PCI Geomatics Help Center

How can we help you today?

Change Detection Optical

PCI Geomatics -

The purpose of this tutorial is to provide you with a friendly and easy to follow step-by-step guide for using the Change Detection algorithms for Optical Functions in PCI Geomatica 2015. This tutorial outlines change detection using the CHDETOP and EXPOLRAS algorithms.

CHDETOP - Detects differences between two input raster images ("new" and "reference"). Typically, the function is used on a pair of images from the same optical satellite sensor and depending on the sensor; tasseled caps can be used to determine the changes.

EXPOLRAS - Converts an input raster image to a binary image using a specified threshold value, then extracts polygons from the resulting binary image and filters them based on area and compactness values.

The data for this tutorial can be found at the link below:
ftp://ftp.pcigeomatics.com/pub/support/Data/ChangeDet.zip

 

Geomatica Focus

 

1. Open the Geomatica 2015 Focus application.

2. Navigate to the directory where you extracted the ChangeDet.zip content to.
3. Drag and drop the Level2_OptChgDet.gpr file into the Focus window.
4. A project opens that contains 4 map layers, but only the bottom layer is toggled on.

Description: This is a Landsat-5 TM image captured in 1990 of the Prince George area in Northern British Columbia, Canada. This area is well known for the logging activities that occur here. This particular image is used as a reference (before) image in order to perform our change detection, which looks to quickly and easily identify vegetation loss (deforestation).

5. Toggle the third layer on.

Description: This is a Landsat-7 ETM+ image captured in 1999 of the same area as described above. This image is used as the input (after) image in which change detection is performed for. Specifically, this demo highlights and extracts areas in the 1999 image where vegetation has been removed.

6. Toggle the first layer and the third layer on and off in sequence. The polygons show where vegetation has been removed for this area.

7. The second layer shows the results from running CHDETOP.

 

Initial Change Detection

1. Return to the Focus window with the Level2_OptChgDet.gpr project loaded
2. In the Focus menu bar, click on Tools > Algorithm Librarian…
3. Navigate to the CHDETOP algorithm

4. Double click on the module or click Open
5. The CHDETOP panel opens with the Files tab active
6. Expand the InputNew tree branch
7. Select all 6 channels from the 1999 image

8. Retract the InputNew branch and expand the InputRef branch
9. Select all 6 channels from the 1990 image
10. Retract the InputRef branch
11. In the Output Ports section (bottom of File tab)
12. Uncheck the Viewer-Grayscale
13. Check C:\PCI Geomatics\...\Untitled.pix
14. Click the Browse… button for Output Ports
15. In File Selector, navigate to C:\...\ChangeDet\change
16. Name the file
17. Click Save
18. Click on the Input Params 1 tab
19. Change the Change detection algorithm to Intensity Ratio

20. Click Run
21. Once the Algorithm has finished running, close the module and minimize the Algorithm Librarian

Note: The output file is automatically added to the project

22. In Focus, click on the Files tab
23. Expand the branch for the top file. This is the file that was just created using CHDETOP.

Description: The output change detection file contains 4 channels. The first channel is a SPANS channel showing an averaged image of the input 6 bands from the 1999 image. The second channel is a SPANS channel showing an averaged image of the reference 6 bands from the 1990 image). The third channel is the absolute values of change, as per the intensity ratio algorithm. The fourth channel is a raster that ranks change based on percentiles (relative change). We will be using the fourth channel for identifying and extracting polygons of deforestation.

24. Right click on the fourth channel (Ranked Changes in Percentiles) and select View > As Pseudocolor

25. The  change image loads into Focus

 

26. Toggle this layer and the 1990 image layer on and off to show the deforestation change. Change in both images is visible in pink while blue represents no change.

 

EXTRACT CHANGE AS POLYGONS

1. Restore the Algorithm Librarian window

2. Navigate to the EXPOLRAS algorithm

3. In the Files tab, click Channel 4 (Ranked Changes in Percentiles) from the CHDETOP output file

4. Click Input Params 1 tab
5. Set the Threshold minimum value to 90
6. Set the Minimum area (pixels) to 250
7. Leave all other values as default

8. Click Run

Description: Once the process has completed, the polygons will automatically be rendered in the viewer

9. Close The EXPOLRAS module and the Algorithm Librarian
10. In Focus, zoom to 1:1
11. Toggle the Ranked Change layer off
12. The polygons do a very nice job of outlining the areas where deforestation has occurred. This can be accomplished by toggling the 1999 image on and off.

Note: The area report or the change detection and extract polygon algorithms can be created for identifying and extracting other forms of change (i.e. new vegetation).

 

GENERATING AN AREA REPORT
1. Open Algorithm Librarian – In the Focus menu bar, click on Tools  Algorithm Librarian…
2. Navigate to the AREAREPORT algorithm
3. Click Open or double click on the module

4. In the Files tab, expand the Files tree branch and select the raster channel named “Area”
5. Click on the Input Params1 tab, and change Reporting Units to any unit that makes the most sense for your area (i.e. Square Kilometres)
6. Click Run

7. After the progress bar disappears, click on the Log tab

Description: The log above shows the total area that has been deforested as well as a relative measure.

Have more questions? Submit a request

Comments

Powered by Zendesk