Take me to pcigeomatics.com

PCI Geomatics Help Center

How can we help you today?

Creating Charts

PCI Geomatics -

Charts can be created of layer attributes to assist in the analysis and presentation of the data. Various chart types are available: pie, column, bar, line, and scatter plots. More than one chart can be created for a particular layer. Changes made to layer attributes would be reflected in a chart. There are different file formats for the chart to be exported to, such as .jpg and .tif.

Step 1: Activate chart tool

1. Open the Attribute Manager of the layer of which a chart is to be made:

  • Right-click on layer name in Maps tab and select Attribute Manager OR
  • Click on the layer name in the Maps tab and go to Layer > Attribute Manager in the menu bar.


2. In the Attribute Manager, select the records for graphing:

  • Use the SHIFT key to manually select the records
  • Alternatively enter a query expression to select a particular set of records. Go to Record > Query by > Example to open the expression dialog box

 

To enter query expression:

  • select an attribute and a relational operator
  • select an attribute value by either selecting from the list (click on Attribute option) or manually input the value in New Statement
  • select AND or OR operator (the expression will be shown under New Statement)
  • click on the Add button
  • if the query expression is complete, click on the Apply button and the records will be shown to be selected on the Attribute Manager

3. Once records are selected, go to Tools > Chart and select the desired chart type. A preview of the chart will be displayed. Please note that the chart illustrates each selected record.

Below are two chart examples:

  1. Column chart of area of manually selected records
  2. Pie chart of vegetation types with an area between 100 and 200 unit area (a more representative chart would be to divide the pie chart based on vegetation types, not individual records)

Step 2: Define Chart

Charts can be customized using the various tools in the Chart Viewer toolbar:

  1. Click on the Chart Definition icon
  2. In the subsequent window, under the Definition tab, select the attribute to be graphed. The type of chart can be changed. Under the Options panel, chart title, axis heading, and other chart properties can be specified. Chart type and Legend can be specified using the corresponding icons in the toolbar as well.

 

Step 3: Export Chart

After chart is defined, it can be exported to a variety of formats.
Click on the Export Chart icon and specify the file name and file format in the Export Chart panel.

 

To Group Records

Charts can represent records that are grouped based on a particular attribute.

1. Select records either manually or by a query (as described above).

2. Go to Tools > Aggregate Attributes.

3. In the subsequent panel, check off the option “Aggregate selected shapes only.” Select the attribute(s) to which the records are to be grouped in.

Click on the Advanced button to include other fields in the chart if necessary.

4. Click on the Aggregate button.



5. The result of grouping selected records will be shown in the subsequent window.

6. Go to Tools > Charts and select chart type. The following prompt will be displayed, Click Yes and enter in a file name in the subsequent New Item Detected window.



The selection is not permanently saved at this stage. A prompt will appear when the Chart Viewr is closing, asking if the layer needs to be saved. Afterwards, the Chart Viewer will open.

7. In the Attribute Manger: Aggregate window, select the records to be included in the chart. There is an option to select all records: Record > Select All

8. After records are selected, click on the Chart Definition icon and specify the field(s) to chart. Click Apply and the chart will be shown in the Chart Viewer.

Have more questions? Submit a request

Comments

Powered by Zendesk